Gutenberg Fields Middleware v0.3.0 with WordPress 5.0 Support

As in the past few months many great changes were made in Gutenberg – the new editing experience in WordPress, our Gutenberg Fields Middleware project needed some updates to work with the upcoming release of WordPress 5.0.

Today, we are releasing Gutenberg Fields Middleware v0.3.0, which works well with WordPress 5.0 (tested with 5.0-RC1). 🎉

This version does not add any new field or feature, it just fixes the issues with the latest Gutenberg changes.

If you haven’t heard about our Gutenberg Middleware project before – it’s a middleware library that makes it easy to register fields for Gutenberg blocks. It avoids the need to write down a lot of repetitive codes.

When you register a block using wp.blocks.registerBlockTypeit allows you define your fields attributes make up your block and it uses the same configuration/array, to create those fields, using Gutenberg’s block API so you have to write less code.

It can be used as a WordPress Plugin or by using its NPM package. Currently it has most of the basic fields however there are several improvements and enhancements that can be made, which would be added in the future releases.

Thanks to Ajit Bohra and Yahil Madakiya for their contribution in v0.3.0.

Link: Gutenberg Middleware 0.3.0

Leave a Reply